Sorry, we don't support your browser.  Install a modern browser

Opera Browers#33

Neatclip support Opera Browers would be nice to have

Shield
7 months ago
1

You CAN use this with Opera, since Opera uses Chromium you have the chose when you go to the google chrome extensions store to install the compatibility pack, it comes up when you try to download a chrome extension in opera, then you have to go to your extensions in opera to accept chrome extensions then it will work.

Mitch.hailey
2 months ago
1